User Tag List

Results 1 to 3 of 3

Thread: A major bug in 2.52 with animation

  1. #1
    Gel
    Join Date
    Jan 2018
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    vBActivity - Stats
    Points
    24
    Level
    2
    vBActivity - Bars
    Lv. Percent
    7%
    Daily Activity
    0%
    Weekly Activity
    40%
    Monthly Activity
    54.18%

    Unverified Bug A major bug in 2.52 with animation

    No clue how to fix this, obviously, but I've gathered as much information on this as possible.

    Basically, I have a section where I have combos are cycling to other combos, which is itself very unreliable, but the bug is where
    an animating combo isn't keeping the same tile it's been assigned.

    What is happening is any combo past combo ID 1680 is glitched.
    So when you open the combo editor, animation pauses. When this happens, these glitched combos reset the count of what animation frame it's at, but changing the animation.
    Therefore, what happens is, say you have a combo animating between 10 frames. You edit a combo while it's on it's 6th frame of animation in the editor. The editor then treats it's 6th frame as it's 1st frame, so it animates frames 6-10, and then an extra five frames past it's 10th frame, then it resets back to frame 6.
    Obviously this breaks everything, as very quickly you can have combos animating nowhere near the correct tiles.

    Now, a few more things to mention about this bug.
    1) This only happens if the checkbox "Refresh animation on room entry" is checked
    2) If you disable animation in the editor, then the bug will not happen, however see point 3
    3) If animation is disabled in the editor, then "Refresh animation on room entry" will not work regardless of if the checkbox is checked or not.

    Now, I need this bug to not happen, but I also need to refresh the animation on room entry.
    What irritates me is that it used to work, and I have half of this section I'm making working perfectly fine, but past a certain combo ID, the combo's don't work. And it's every single combo that doesn't work past this ID. I've tried closing and reopening the program, inserting/removing combos, but nothing works.

    Any help would be appreciated.

  2. #2
    The Timelord
    ZC Developer
    ZoriaRPG's Avatar
    Join Date
    Oct 2006
    Location
    Prydon Academy
    Posts
    1,151
    Mentioned
    103 Post(s)
    Tagged
    1 Thread(s)
    vBActivity - Stats
    Points
    3,945
    Level
    19
    vBActivity - Bars
    Lv. Percent
    99.43%
    Daily Activity
    4642.86%
    Weekly Activity
    740%
    Monthly Activity
    223.48%
    Quote Originally Posted by Cavin856 View Post
    No clue how to fix this, obviously, but I've gathered as much information on this as possible.

    Basically, I have a section where I have combos are cycling to other combos, which is itself very unreliable, but the bug is where
    an animating combo isn't keeping the same tile it's been assigned.

    What is happening is any combo past combo ID 1680 is glitched.
    So when you open the combo editor, animation pauses. When this happens, these glitched combos reset the count of what animation frame it's at, but changing the animation.
    Therefore, what happens is, say you have a combo animating between 10 frames. You edit a combo while it's on it's 6th frame of animation in the editor. The editor then treats it's 6th frame as it's 1st frame, so it animates frames 6-10, and then an extra five frames past it's 10th frame, then it resets back to frame 6.
    Obviously this breaks everything, as very quickly you can have combos animating nowhere near the correct tiles.

    Now, a few more things to mention about this bug.
    1) This only happens if the checkbox "Refresh animation on room entry" is checked
    2) If you disable animation in the editor, then the bug will not happen, however see point 3
    3) If animation is disabled in the editor, then "Refresh animation on room entry" will not work regardless of if the checkbox is checked or not.

    Now, I need this bug to not happen, but I also need to refresh the animation on room entry.
    What irritates me is that it used to work, and I have half of this section I'm making working perfectly fine, but past a certain combo ID, the combo's don't work. And it's every single combo that doesn't work past this ID. I've tried closing and reopening the program, inserting/removing combos, but nothing works.

    Any help would be appreciated.
    Would you mind providing a sample quest that exhibits this condition?

    Is this bug only in ZQuest, or does it occur when you play the quest in ZC, too?


    Featured Scripts & Headers: RPG.zh ( v. a0.97.1 ) ( RPG.zh Thread ) | Zelda 3 Thief's Town Treasure Chest Minigame (ffc) | Bobomb (enemy)
    ZScript & ZC-Related Pastebin | Quests and ZScript Repository | ZC Dev & Betas | Latest ZC 2.54 Beta | YouTube Channel
    All of the code that I create and publish here is free for use, modification and distribution under the GPL v2.0, or v3.0 where applicable..

  3. #3
    Gel
    Join Date
    Jan 2018
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    vBActivity - Stats
    Points
    24
    Level
    2
    vBActivity - Bars
    Lv. Percent
    7%
    Daily Activity
    0%
    Weekly Activity
    40%
    Monthly Activity
    54.18%
    I made a quick video showing the bug in detail. I was unable to reproduce it on a blank quest, but that doesn't mean it won't happen, just that my 2 seconds of testing didn't trigger it. So obviously something else that I did in my quest is affecting and causing this bug, but as to what, I have no idea, since it's in the combos itself, even if I don't place them down. I also confirmed that yes, it does affect ZClassic in game as well, not just ZQuest.
    I'm also linking a dropbox with a copy of my quest with the bug.

    Video: https://www.youtube.com/watch?v=JL7r...ature=youtu.be
    Quest: https://www.dropbox.com/s/moyf8sg0ps...20Zat.qst?dl=0

    Obviously to anyone else viewing this, yes, this is my uncopylocked quest. Don't steal it please.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •