User Tag List

Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18

Thread: Zelda Classic 2.50.3 RC1

  1. #11
    Administrator War Lord's Avatar
    Join Date
    Feb 2000
    Age
    36
    Posts
    6,026
    Mentioned
    52 Post(s)
    Tagged
    0 Thread(s)
    vBActivity - Stats
    Points
    1,304
    Level
    12
    vBActivity - Bars
    Lv. Percent
    30.29%
    Quote Originally Posted by Saffith View Post
    I think I might have found the problem. Apparently Sierra has a new security feature called translocation that can prevent an application from finding its data files. That sounds like what you're seeing.
    Try this: in Finder, click and drag ZC to a different folder and run it there. Supposedly, that will disable translocation. You can presumably move it back afterward.
    Great catch @Saffith . I do believe that to be his issue after reading it. I have not experienced behavior like that on my mac at work but I don't download and run things out of Downloads often.

    The basic gist is that if you download and run a Gatekeeper app from the Downloads folder, the OS will copy the app into a read-only disk image and run it from there instead. See the link above for more details.

  2. #12
    Keese luckilla's Avatar
    Join Date
    Oct 2013
    Location
    Ohio
    Age
    44
    Posts
    66
    Mentioned
    2 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    439
    Level
    7
    vBActivity - Bars
    Lv. Percent
    57.3%
    I got it to now work for me. It downloaded all the quest files, then I downloaded the Zelda classic app, so I think that was the problem. I did not realize this was what I needed to do(I thought files were built right into the build itself?!?!?, but everything is good now, thanks for the ideas and help.
    Last edited by luckilla; 12-11-2016 at 02:04 PM.

  3. #13
    Administrator War Lord's Avatar
    Join Date
    Feb 2000
    Age
    36
    Posts
    6,026
    Mentioned
    52 Post(s)
    Tagged
    0 Thread(s)
    vBActivity - Stats
    Points
    1,304
    Level
    12
    vBActivity - Bars
    Lv. Percent
    30.29%
    Quote Originally Posted by luckilla View Post
    Thank you guys for pinpointing the problem. I wish I could get it to work, I am going to keep trying to figure this one out. If anyone has a good idea please let me know.
    You've moved it out of the downloads folder like to your desktop and it still does the same thing?

  4. #14
    Is this the end?
    ZC Developer
    Saffith's Avatar
    Join Date
    Jan 2001
    Age
    37
    Posts
    3,384
    Mentioned
    178 Post(s)
    Tagged
    6 Thread(s)
    vBActivity - Stats
    Points
    6,242
    Level
    24
    vBActivity - Bars
    Lv. Percent
    38.15%
    I found another thing. Someone said having two applications packaged together seems to confuse it. So try this: in Finder, move ZC and ZQuest into two different folders, then move them back. Maybe that'll do it.

  5. #15
    Keese luckilla's Avatar
    Join Date
    Oct 2013
    Location
    Ohio
    Age
    44
    Posts
    66
    Mentioned
    2 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    439
    Level
    7
    vBActivity - Bars
    Lv. Percent
    57.3%
    It looks like it (all the Mac builds) does not need the files it saved to run, the only thing that makes it run is being game folder. For some reason it seems any game folder is like a happy spot for the build to run correctly. it did not work correctly in the applications folder. This is weird, but at least I figured out how to fix the problem now.
    Last edited by luckilla; 12-11-2016 at 04:16 PM.

  6. #16
    Keese luckilla's Avatar
    Join Date
    Oct 2013
    Location
    Ohio
    Age
    44
    Posts
    66
    Mentioned
    2 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    439
    Level
    7
    vBActivity - Bars
    Lv. Percent
    57.3%
    I was playing the 5th quest on 2.50.3 RC1 and noticed 2 weird bugs. One bug was sometimes when playing - Link will just walk somewhere and not stop sometimes I can stop this from happening, but seems like bug. This only happens once in a while. Another glitch is sometimes the screen saver comes on too soon. These issues are with the Mac build just for clarification.

  7. #17
    Is this the end?
    ZC Developer
    Saffith's Avatar
    Join Date
    Jan 2001
    Age
    37
    Posts
    3,384
    Mentioned
    178 Post(s)
    Tagged
    6 Thread(s)
    vBActivity - Stats
    Points
    6,242
    Level
    24
    vBActivity - Bars
    Lv. Percent
    38.15%
    Quote Originally Posted by luckilla View Post
    One bug was sometimes when playing - Link will just walk somewhere and not stop sometimes I can stop this from happening, but seems like bug.
    That sounds like a key getting stuck or a key release not registering. Neither would be a bug, exactly. Does it happen more than before? Might be due to a change in 10.12, but I don't know what that might be...

    Another glitch is sometimes the screen saver comes on too soon.
    The game's screen saver or the OS's? The game's screen saved should be disabled by default. The OS's we probably can't do anything about.

  8. #18
    Keese luckilla's Avatar
    Join Date
    Oct 2013
    Location
    Ohio
    Age
    44
    Posts
    66
    Mentioned
    2 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    439
    Level
    7
    vBActivity - Bars
    Lv. Percent
    57.3%
    It was the game's screen saver. Thank you for the info about the key getting stuck. It does not happen often when playing, but happens a few times when playing. Just trying to make sure these are not issues before 2.50.3 get released. I did not notice any other issues.
    Last edited by luckilla; 12-13-2016 at 12:44 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Armageddon Games is a game development group founded in 1997. We are extremely passionate about our work and our inspirations are mostly drawn from games of the 8-bit and 16-bit era.
Social