User Tag List

Results 1 to 3 of 3

Thread: ZQuest: Link Tile Extend bugged in 2.50 and 2.50 RC3

  1. #1
    Lynel Dart Zaidyer's Avatar
    Join Date
    Apr 2001
    Location
    Rand McNally
    Age
    31
    Posts
    1,943
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    vBActivity - Stats
    Points
    2,838
    Level
    17
    vBActivity - Bars
    Lv. Percent
    31.42%
    Daily Activity
    0%
    Weekly Activity
    70%
    Monthly Activity
    45.15%

    Not A Bug ZQuest: Link Tile Extend bugged in 2.50 and 2.50 RC3

    This bug was tested only on Windows builds.
    The behavior of this bug varies from quest to quest, yet produces consistent results once it occurs, and seems somehow related to the graphics data in the quest file.
    Everything appears normal in ZQuest, the bug only manifests when playing the quest file in Zelda.exe.

    Quests made in older builds seem to work normally until Extend is changed for a given entry in the "Graphics>Sprites>Link" menu in ZQuest. In one quest, the result was that the upper and lower halves of the sprite were fully swapped with each other; the bottom was on top, and the top was on bottom.

    If the bug occurs on an existing quest, exporting a ZGP and importing it into another quest will carry over the specific results of the bug. (In the above case, the swapping of halves was preserved in the ZGP.)

    Creating an entirely new quest and setting Extend on any of Link's sprites while also selecting a different tile will cause zelda.exe to animate with tiles that are not at all what was selected.
    ~Dart Zaidyer

  2. #2
    Is this the end?
    ZC Developer
    Saffith's Avatar
    Join Date
    Jan 2001
    Age
    35
    Posts
    3,348
    Mentioned
    171 Post(s)
    Tagged
    6 Thread(s)
    vBActivity - Stats
    Points
    6,077
    Level
    24
    vBActivity - Bars
    Lv. Percent
    10.73%
    Daily Activity
    0%
    Weekly Activity
    70%
    Monthly Activity
    45.15%
    Can you provide a quest that's been affected by this?
    [téknolŕiz]

    ffcscript.zh 1.1.1 - Updated 2014-08-19
    ghost.zh 2.8.2 - Updated 2017-09-10
    tango.zh 1.3.1 - Updated 2017-12-27

  3. #3
    Lynel Dart Zaidyer's Avatar
    Join Date
    Apr 2001
    Location
    Rand McNally
    Age
    31
    Posts
    1,943
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    vBActivity - Stats
    Points
    2,838
    Level
    17
    vBActivity - Bars
    Lv. Percent
    31.42%
    Daily Activity
    0%
    Weekly Activity
    70%
    Monthly Activity
    45.15%
    I've done some further testing and learned that this is not a bug, it's just that most modern tilesets (including the default one when you start a new quest) now use Link Tile Mods for the "small shield" item, offsetting the graphics and producing what looked to me like a bug.

    I feel like such an old man. Why back in my day, there was no Small Shield, Link just had one all the time!
    ~Dart Zaidyer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •