View Full Version : Music plays at light speed on Ubuntu 12.04

08-31-2012, 07:21 PM
I just tried playing the Linux build of RC 4 on Ubuntu 12.04, and both the music and the sound plays at many times the usual speed (with the rest of the game running at the right FPS).

09-01-2012, 11:47 AM
I think I know what you mean. It doesn't stay that way for long, does it? When I've seen that before, it's only lasted a matter of seconds. I suspect it's an issue with either Allegro or PulseAudio, but I can't reproduce it consistently enough to pin it down.
Are there any messages if you run in a terminal?

09-08-2012, 12:30 PM
Unfortunately not -- it seems permanent (in 1st.qst I picked up sword and traveled to the first dungeon without the sound fixing itself).

There's nothing in the terminal.

09-08-2012, 01:34 PM
In that case, could you check whether it happens in RC 1 or 2? I think it might have started in RC2, but I haven't been able to confirm that. If it's a compilation issue, it probably shouldn't be hard to fix.

09-08-2012, 03:19 PM
I tried RC2; same problem.

09-10-2012, 11:50 AM
What about different settings for digi_card in the sound section of ag.cfg? I think the valid settings are ALSA, OSS, ESD, and JACK. Do any of those work better?

Also, did you try toggling the framerate cap? I think that affects it.

11-02-2012, 10:03 AM
See if this is any better: http://filesmelt.com/dl/zelda-l

Edit: changed the file

12-15-2012, 12:26 AM
I'm pretty sure now that this isn't our problem. I've found that the same thing occurs with Allegro's own test programs, apparently regardless of the environment they were compiled in (though I didn't try 64-bit versions). I think this must be an ALSA or PulseAudio issue.

02-05-2013, 04:21 PM
I am using Debian Wheezy and the audio was ok initially then started to play fast.
Any ideas on how to fix this?