PDA

View Full Version : Using Zelda Classic v1.90 in Pure DOS



ZeldaFan001
03-14-2004, 01:45 AM
What would you say I should have? I am not able to play DOS Sound in Windows 98, so I am forced to play Zelda Classic in Pure DOS because I have Pure DOS sound drivers. Until I figure out my sound card problem, I have to resort to this.

Which got me interested, how much memory should I have or what should the conditions be to run Zelda Classic properly?

I have a common problem of picking up an item and link holding it in the air. This is the error message I get when picking up the boomerang in Sludge's ALTADD quest:



Shutting down Allegro
Exiting due to signal SIGSEGV
Page fault at eip=0002al0f, error=0004
eax=00000000 ebx=00312d0c ecx=00000000 edx=00000000 esi=003120dc edi=001439c0
ebp=001db878 esp=001db830 program=C:\ZELDA\ZELDA.EXE
cs: sel=00a7 base=10000000 limit=0080ffff
ds: sel=00af base=10000000 limit=0080ffff
es: sel=00af base=10000000 limit=0080ffff
fs: sel=00bf base=0000000 limit=0010ffff
gs: sel=00bf base=0000000 limit=0010ffff
ss: sel=00af base=10000000 limit=0080ffff
App stack: [001db9ac..0015b9ac] Exceptn stack: [0015b904..001599c4]

Call frame traceback EIP's:
0x0002a10f
0x0001f4bc
0x0004769b
0x000488d5
0x000b85b2


Any idea of what's going on and how to solve my sound problem?

Have a Mach Speed VIA Apollo Pro Vt82C694T/82C686B Chipset with PIII 1,000mhz Processor and Onboard Sound

DOS programs detect sound card I use, but you hear nothing.

P.S. Changing sound cards didn't work. I had a seperate Sound Blaster card (unknown of type) that has same problem.

Teilyr
03-14-2004, 05:56 AM
Here's my question.

Why in the blue hell do you want to use 1.90?

ShadowTiger
03-14-2004, 10:15 AM
That is a good question. O_O' You should really use 1.92. It's far more than stable enough to use. Otherwise, people wouldn't be using it. :p (.. And yes, this is one of those things that you should remember forever.)

And I've definitely gotten that screen before. I think it happens when you quit from ZC really fast. :p

Questwizard88
03-14-2004, 11:31 AM
You should definitely start using 1.92. The processor you have is surely fast enough to run it at the right speed, and you have a very good chance of not having a single sound problem with it.

ZeldaFan001
03-14-2004, 01:09 PM
I guess I will consider using it, but I'm playing v1.90 quests with 1.90, so that no problems will come up with using old quests with new betas. That's my reason.

Again, the problem is caused by getting an item that Link holds above his head.

All DOS games that I run in Windows 98, you can't hear any sound. I don't know what is causing this problem, but so far, my only solution is just getting into pure DOS to play, (and it v6.22 by the way).

Teilyr
03-14-2004, 01:25 PM
1.90 required that you run agsetup.exe. It should be in your ZC folder.

Play with some of the settings in that and see if you can get some sound going.

Freedom
03-14-2004, 01:34 PM
here's the info I grabbed when I had that problem....


If you run AG setup.exe, then go to midi driver, it'll ask you for your sound card and give you a list. If yours isn't on the list, it's not compatible.

Okay, don't mess with the patches and such... leave them at default. Try changing your midi device to either "MPU-401" or "Midi Out". Don't use auto-detect: it'll usually give the generic "Adlib" option, which is probably what the problem is.

Thank you Overdrive it worked!

Ok Tudorcat this is what you should do!

1-Go into AGSetup
2-Go to Digital Driver
3-Click on Generic SB
4-Listen to what the bottom screen says and set everything to what the "usually" is.
5-Click ok
6-Go to the other sound option
7-Select MPU-401
8-Select everything to what the bottom screen says
9-Click ok, save the changes.
10-Run Zelda

Boomaster choose MPU-401 anyway. Let me tell you that I don't have a Generic SB or MPU-401 but it worked. Choose it anyway then in the options screen set the stuff to what the bottom screen says. Click ok, and run Zelda.

If this doesn't work just keep playing around with all the sound cards and save. Eventually something should work. After trying a sound card imediately set the options and save and run Zelda.

DON'T DO A SOUND TEST IN AGSETUP, IT WILL FAIL!

DO A SOUND TEST ONLY IN THE ZELDA GAME!

--------------------------
what I did for mine
--------------------------

set Digital Driver to "Soundblaster Pro" and "usual" settings as instructed by the Agsetup.exe
set Midi Driver to "Adlib (opl2) and "usual" settings.

ZeldaFan001
03-14-2004, 01:41 PM
Remember, this sound problem isn't just directed towards Zelda Classic in DOS. ALL GAMES I play in Windows 98 using the DOS Prompt gets me no sound. These programs detect the sound card correctly, but no sound is heard. I think Windows is somehow causing this problem, so I just get out of Windows completely to make sound work.

Why don't I just use 1.92 for these 1.90 quests? A good example is C-Dawg's Dreams of Yesterday quest. It's safe to play in Build 152 because that is what it was designed for, but use a later beta such as Build 163, and you run into bugs that prevent you from completing the game.

Freedom
03-14-2004, 03:25 PM
I've had to make adjustments on all the zelda classic programs to get proper sound, I have the 184, 190, 192/153, 192/163 192b182, /183, /184 the new 184 player is the only one I haven't had to tweak to get proper sound, although at first it was triggering sounds twice, I had to swap out the sfx.dat to correct that.
I have them all in different folders where I can use any one of them at any time.
I'm running windows 98 with a crystal sound fusion sound card.

The new 184 player is the only one I use in windows, the rest I use the DOS shell.
I think you have a sound card problem, and the item sound is dropping you out.

Teilyr
03-14-2004, 04:06 PM
Why are you using the dosprompt?

Double click on zelda.exe and play. O_o

bigjoe
03-14-2004, 04:55 PM
Why are you using the dosprompt?

Double click on zelda.exe and play. O_o
Remember, this sound problem isn't just directed towards Zelda Classic in DOS. ALL GAMES I play in Windows 98 using the DOS Prompt gets me no sound.
You should really learn to read people's posts.I don't mean to be rude,or rent a mod, but a lot of the times it will seem like you're not even thinking about the content of your posts when you post. This level of topic-overlooking disturbs me that much.

Anyway, have you installed/run CWSDPMI, ZeldaFan?

If not, get it here:

http://www.zeldaclassic.com/csdpmi4b.zip

Qun Mang
03-14-2004, 06:07 PM
Have you tried VDMSound? It's primarily for Win NT/2000/XP, but there is a version for Win98 in development (with an alpha release- no promises that it will work for you).

VDMSound Messageboard (http://vogons.zetafleet.com/index.php?c=6&sid=37aeb96ca0e248dcc00616d91a2f6171
)

Win98 Version Discussion (http://vogons.zetafleet.com/viewtopic.php?t=900)

ZeldaFan001
03-15-2004, 04:39 PM
Yes, I am using CWSDPMI, because I saw that without it, Zelda Classic didn't open. Here is my problem again as detailed as I can.

I have a dual boot between Windows 98 and just plain DOS.

When I use plain DOS to run Zelda Classic, everything works great. I get proper sound, nothing screwy happens, but when I pick up an item, then Zelda Classic crashes and gives me that error message.

If I then load Windows 98, load Zelda Classic using the same addresses and sound card I used in Plain DOS to get sound working, the sound will not play, even though Zelda Classic DETECTS the sound card I am using. BUT, if I pick up an item in Zelda Classic while running Windows 98, I get no problem and the game runs normally, just no sound.

Is there any way I can find out what settings Windows is using to get sound working? If I can find out, I can solve this problem.

I have 2 problems and here is the short version:

Using Windows gets me no sound in DOS.

Using Zelda Classic in just DOS with NO Windows running makes Zelda Classic crash when I pick up an item.

How can I solve these problems?