PDA

View Full Version : Help with ZC sound



iceman
01-26-2004, 01:20 PM
I just downloaded four files from casadealphadawg.com to play zelda classic and I cant get the midi's to play in the game. EX. overworld midi and so forth. I get sound effects but no theme music. Need your suggestions. Thanks

zc192b163w.exe, zc192b163s.exe, alleg40.dll, sfx.dat are the files I downloaded.

Raichu86
01-26-2004, 02:25 PM
Suggestions:

1. Check your mixer's MIDI volume.
2. Check ZC's midi volume (it's in the menus). Unlikely to be the problem since you just got ZC, but worth a try.
3. If still no go, tell us your sound card brand and model.

Freedom
01-26-2004, 03:02 PM
here's the info I grabbed when I had that problem....


If you run AG setup.exe, then go to midi driver, it'll ask you for your sound card and give you a list. If yours isn't on the list, it's not compatible.

Okay, don't mess with the patches and such... leave them at default. Try changing your midi device to either "MPU-401" or "Midi Out". Don't use auto-detect: it'll usually give the generic "Adlib" option, which is probably what the problem is.

Thank you Overdrive it worked!

Ok Tudorcat this is what you should do!

1-Go into AGSetup
2-Go to Digital Driver
3-Click on Generic SB
4-Listen to what the bottom screen says and set everything to what the "usually" is.
5-Click ok
6-Go to the other sound option
7-Select MPU-401
8-Select everything to what the bottom screen says
9-Click ok, save the changes.
10-Run Zelda

Boomaster choose MPU-401 anyway. Let me tell you that I don't have a Generic SB or MPU-401 but it worked. Choose it anyway then in the options screen set the stuff to what the bottom screen says. Click ok, and run Zelda.

If this doesn't work just keep playing around with all the sound cards and save. Eventually something should work. After trying a sound card imediately set the options and save and run Zelda.

DON'T DO A SOUND TEST IN AGSETUP, IT WILL FAIL!

DO A SOUND TEST ONLY IN THE ZELDA GAME!

--------------------------
what I did for mine
--------------------------

set Digital Driver to "Soundblaster Pro" and "usual" settings as instructed by the Agsetup.exe
set Midi Driver to "Adlib (opl2) and "usual" settings.

iceman
01-26-2004, 03:17 PM
Thanks guys I got it working. One more question but this is completely different. How do you go about playing other peoples quests. I went to purezc to download some quests to play and opened up zquest.exe. Now I am lost. Please help. Thanks

Petoe
01-26-2004, 04:08 PM
Originally posted by iceman
Thanks guys I got it working. One more question but this is completely different. How do you go about playing other peoples quests. I went to purezc to download some quests to play and opened up zquest.exe. Now I am lost. Please help. Thanks
http://www.armageddongames.net/forums/showthread.php?s=&threadid=59715
Click that link. It tells you how to play custom ZC quests (other people's quests).
But if you want to play all the newest quests, you have to get the newest version of ZC. You seem to have just the build 163. ZC build 183 is what you should get. Get it here: http://www.casadealphadawg.com/zc/ and download the file called "zc192b183w.zip" and the new support files "zc192b182s.exe".

:)

Raichu86
01-26-2004, 04:45 PM
Don't forget to copy your ag.cfg file to the new location when you get 183 so you don't have to fix the sound again. You'll need to update the quest dir from Zelda.exe, of course.

iceman
01-26-2004, 05:24 PM
Thanks again guys. Some of the work in the custom quests is really something. Now all I need is a joystick and I will be set. Playing on the keyboard is abit of a pain. :thumbsup: