PDA

View Full Version : Windows error? HELP!



kellyau
11-30-2003, 06:41 PM
Hi,
I just downloaded and unzipped ZC and get a
windows error message when i try to start it. You know the one...
"zelda-w has encountered a problem and needs to close"
Then I get to send an error report to microsoft which tells me
nothing.

Any ideas:confuse2:

Axel
12-01-2003, 03:29 PM
yeah, same problem here. no idea what's causing it.

*b*
12-01-2003, 03:44 PM
you either need a new version of Allegro.dll, or some updates from Microsoft. this, for me, usually dosen't last long, so don't worry too much

Axel
12-03-2003, 02:42 PM
ok, that problem solved itself, but now I have a new one.
Link is moving insanely fast on my screen, so I switched on Vsync, and he moves insanely slow. I switched to "show FPS" to catch what's going on. With Vsync the FPS never goes above 25/60, without it it never drops below 250/60. How do I fix this?

Cloral
12-03-2003, 03:24 PM
Which version are you using? DOS or Windows?

kellyau
12-03-2003, 03:57 PM
Originally posted by Cloral
Which version are you using? DOS or Windows?

I'm using the Windows version, I ran Windows update to
see if that would solve the problem but no luck and the Allegro version I have is 4.1.7.

Freedom
12-03-2003, 06:41 PM
Kellyau,
did you run zquest.exe and get a ag.cfg file?
if not try that first.


Axel,
I had those problems with the 182 player, but the 183 player fixed it.
If you aren't running the 183 you might try that, it's in the quest archive

kellyau
12-03-2003, 08:27 PM
Thanks Freedom,
I ran quest first and now the game will open but there
is a new problem, everything in the game moves
about 10 times faster than it should and the text
is doubled up and I can't read it.

Freedom
12-03-2003, 09:27 PM
same answer I gave axel then.
use the 183 player, rename the 182 player to xzelda.exe and just put the new player in the same folder, that way if you ever want the 182 player again you just have to rename it back.

kellyau
12-07-2003, 10:24 PM
Originally posted by Freedom
same answer I gave axel then.
use the 183 player, rename the 182 player to xzelda.exe and just put the new player in the same folder, that way if you ever want the 182 player again you just have to rename it back.

Ok, I used the 183 player but i'm still having a problem
which I now realize is not just the text doubled up but every
image on the screen. I can play the game but I really have
to concentrate to read anything because it looks almost blurry
due to the doubling.

Freedom
12-07-2003, 10:43 PM
That sounds like a resolution problem, you might try some different settings.
I'm not sure about that though, because I haven't had any problems like that.

I would think you would have better luck using DOS instead of windows, I haven't had any problems with DOS but windows was kind of a problem, so I just stuck with DOS and didn't worry about it :)

what version of windows do you run?

98?
xp?

Cloral
12-08-2003, 12:20 AM
Try running it windowed and see if that helps. I had graphics problems under fullscreen that dissapeared when running it windowed (add the -windowed switch to the command line).

Axel
12-08-2003, 03:31 PM
where can you get 183? Alphadawg's downloads don't work (see: where to download) and PZC doesn't have the downloads section anymore.

gameguy032
12-08-2003, 03:52 PM
I just tried AlphaDawg's page...

Works for me. Did you try left-clicking?

Axel
12-09-2003, 04:00 PM
I always left-click first, then try "save target as..." as I've said in several topics (including the one I just referenced) neither works.

Freedom
12-09-2003, 05:24 PM
The 183 player is in the quest database here

Verbatim
12-09-2003, 05:24 PM
Originally posted by kellyau
Ok, I used the 183 player but i'm still having a problem
which I now realize is not just the text doubled up but every
image on the screen. I can play the game but I really have
to concentrate to read anything because it looks almost blurry
due to the doubling.

What kind of a monitor do you have? If it's a CRT, just ignore this post...if it's an LCD/flatscreen...most of those are set to stretch things so that they fill up the whole screen, which makes them look pretty bad...

What you need to do to turn off that stretching would depend on what kind of a monitor you have...if it connects digitally, you need to right-click the desktop, go to properties, click the "settings" tab, click the advanced button, and then hunt around...where the setting is depends on your video-card, mine is under "*ATI-logo* displays"->'panel'->"scale image to panel size".

If it connects (like most desktop ones still do) with a standard analog monitor plug, you'll need to hunt in your monitor's menus.

When you turn off the stretching, it'll be less fuzzy, but it'll probably also be small, you can improve that by adding "-res 640 480 big" to your shortcut...or, heck, if you can't find how to prevent your monitor from stretching it, just put in your monitor's default resolution... eg "-res 1024 768 big", or on my wide-screen monitor, "-res 1280 800 big". It'll make ZC work a little harder to keep up, but you have a fast computer, right?

If you don't know how to add things to the command line under windows, just check out the topic on command line shortcuts, it gets answered a few posts down.

kellyau
12-09-2003, 11:03 PM
Originally posted by Verbatim
What kind of a monitor do you have? If it's a CRT, just ignore this post...if it's an LCD/flatscreen...most of those are set to stretch things so that they fill up the whole screen, which makes them look pretty bad...

What you need to do to turn off that stretching would depend on what kind of a monitor you have...if it connects digitally, you need to right-click the desktop, go to properties, click the "settings" tab, click the advanced button, and then hunt around...where the setting is depends on your video-card, mine is under "*ATI-logo* displays"->'panel'->"scale image to panel size".

If it connects (like most desktop ones still do) with a standard analog monitor plug, you'll need to hunt in your monitor's menus.

When you turn off the stretching, it'll be less fuzzy, but it'll probably also be small, you can improve that by adding "-res 640 480 big" to your shortcut...or, heck, if you can't find how to prevent your monitor from stretching it, just put in your monitor's default resolution... eg "-res 1024 768 big", or on my wide-screen monitor, "-res 1280 800 big". It'll make ZC work a little harder to keep up, but you have a fast computer, right?

If you don't know how to add things to the command line under windows, just check out the topic on command line shortcuts, it gets answered a few posts down.

Problem solved, thanks so much. Changing the res didn't
make a difference in the size but now I can see everything!
It was that I have an LCD and the stretching.
Thanks again Verbatim,
Kelly