View Full Version : midi problems

07-02-2003, 05:11 PM
the midi on the original zelda games do not play, but the sound effects do. is this normal, or am i missing something? wasn't sure where to ask....:confuse2: :confused:

07-02-2003, 07:30 PM
What version or beta are u using?

07-02-2003, 07:34 PM
I imagine it is some sort of XP problem. I don't know much about ZC, but I know a place where lots of people will be gushing to help you. Hold on...

/me puts two fingers to his forehead and disappears in a flash of light!

07-02-2003, 08:05 PM
I'm using version 1.90......I'm not really that computer literate so i dont' know much more than that

07-02-2003, 11:19 PM
You have to set the drivers to get it to work, I think you'd have better luck with the 192b182 version, but if you would prefer to stay with the 190, you have to open the agsetup.exe and then by trial and error find the one that works with your sound card.

I had to use the soundbbaster driver.

here's the info I collected when I had that problem.

If you run AG setup.exe, then go to midi driver, it'll ask you for your sound card and give you a list. If yours isn't on the list, it's not compatible.

Okay, don't mess with the patches and such... leave them at default. Try changing your midi device to either "MPU-401" or "Midi Out". Don't use auto-detect: it'll usually give the generic "Adlib" option, which is probably what the problem is.

Thank you Overdrive it worked!

Ok Tudorcat this is what you should do!

1-Go into AGSetup
2-Go to Digital Driver
3-Click on Generic SB
4-Listen to what the bottom screen says and set everything to what the "usually" is.
5-Click ok
6-Go to the other sound option
7-Select MPU-401
8-Select everything to what the bottom screen says
9-Click ok, save the changes.
10-Run Zelda

Boomaster choose MPU-401 anyway. Let me tell you that I don't have a Generic SB or MPU-401 but it worked. Choose it anyway then in the options screen set the stuff to what the bottom screen says. Click ok, and run Zelda.

If this doesn't work just keep playing around with all the sound cards and save. Eventually something should work. After trying a sound card imediately set the options and save and run Zelda.



what I did for mine

set Digital Driver to "Soundblaster Pro" and "usual" settings as instructed by the Agsetup.exe
set Midi Driver to "Adlib (opl2) and "usual" settings.

07-04-2003, 03:18 PM
Okay, I have an MPU-401 sound card, and when i go into setup, it's checked off. the no sound thing is checked off to. if i click on the mpu thing, it has a -1 for each of the three sections. do i change those? i'm so confused....

07-04-2003, 04:57 PM
seems if the 'no sound' is checked, then you'll have no sound :O)

use the agsetup.exe and do what it says at the bottom.
When you hold your mouse over a button, instructions scroll across the bottom

07-04-2003, 09:06 PM
the thing with the no sound is that i still had sound effects....but no fear! Through half hazard clicking and fooling around i suddenly have sound effects AND music! Huzzah! Thanks for everyone's help!