User Tag List

Results 1 to 7 of 7

Thread: More 1.84 issues: Tiles Not Saving

  1. #1
    Wizrobe Nightmare's Avatar
    Join Date
    Mar 2000
    Age
    38
    Posts
    2,461
    Mentioned
    38 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    3,398
    Level
    18
    vBActivity - Bars
    Lv. Percent
    73.08%
    Daily Activity
    0%
    Weekly Activity
    1.13%
    Monthly Activity
    2.77%

    More 1.84 issues: Tiles Not Saving

    This is a problem I had with the ORIGINAL example_1st.qst back in 2000 and also with a test quest I made to test another issue:

    Apparently the tiles don't read the same as it seems to read the new ZC tileset rather than the one included with the file from 1.84. The 184 Test Quest I made works fine in 1.84.

    To try to remedy the problem I ripped the tiles from 1.84, saved them there, and tried to import them into the test quest in 2.53 to see if that would fix the problem. 2.53 didn't read the 1.84 tile format.

    For some reason New Quest and Demo kept their tilesets in 1.84 but the new quest didn't. Weird.

    The test quest fails on all versions of 2.50.

    -James

    Facebook: http://www.facebook.com/nightmarejames YouTube: http://www.youtube.com/nightmarejames

    Game Projects
    Zelda Classic:
    Completed: Zelda NES Remastered, Demo 1st Quest, Demo 2nd Quest, James Quest: Remastered (V 2.1), Memorial Quest, New Quest 2 2015. New Quest: Rebuilt
    In development: Demo SP, James Quest: Remastered (V 3.0)t, 6QI

  2. #2
    ZC Contirbutor ZoriaRPG's Avatar
    Join Date
    Oct 2006
    Location
    Prydon Academy
    Posts
    1,029
    Mentioned
    95 Post(s)
    Tagged
    1 Thread(s)
    vBActivity - Stats
    Points
    3,585
    Level
    19
    vBActivity - Bars
    Lv. Percent
    17.45%
    Daily Activity
    197.63%
    Weekly Activity
    29.38%
    Monthly Activity
    9.36%
    Quote Originally Posted by Nightmare View Post
    This is a problem I had with the ORIGINAL example_1st.qst back in 2000 and also with a test quest I made to test another issue:

    Apparently the tiles don't read the same as it seems to read the new ZC tileset rather than the one included with the file from 1.84. The 184 Test Quest I made works fine in 1.84.

    To try to remedy the problem I ripped the tiles from 1.84, saved them there, and tried to import them into the test quest in 2.53 to see if that would fix the problem. 2.53 didn't read the 1.84 tile format.

    For some reason New Quest and Demo kept their tilesets in 1.84 but the new quest didn't. Weird.

    The test quest fails on all versions of 2.50.

    -James
    Do all of these have the same issue, across the board in all 2.50.x releases; or is only one of these that has this issue in all 2.50.x releases?

    James, i do wish that you would be more specific, and detailed. What quest files you tested in each version, and what the result was for each, in each ZC/ZQuest version, linking to the quest files. This level of compatibility is a very marginal concern for most people, and getting it to work properly, or figuring out the causes will take considerable time and effort. As such, it would be extremely useful not to need to duplicate every test from here, that you have already done.

    In general, the best way to report this is something like this:

    Quest File (made in specify version of ZC)
    Test Results for 2.50.0: Quest does this; works right; has these issues.
    Test Results for 2.50.1: Quest does this; works right; has these issues.
    Test Results for 2.50.2: Quest does this; works right; has these issues.
    Test Results for 2.50.3rc1: Quest does this; works right; has these issues.
    Test Results for 2.53.0 Beta n: Quest does this; works right; has these issues.

    If you also feel like testing it in 2.10, you can provide those results, but they may not be helpful at this stage.

    The more detailed your reports are, the easier it will be for us to (1) schedule a series of our own tests, (2) determine a point at which this issue first occurred. (3) examine the issue and search for a root cause, (4) consider a potential fix implementation.

    If none of these quest load tiles properly in any 2.50.x version, then it is possible that the tile loading mechanism for them is simply not properly implemented at all. If it only affects some quests, then it is a much stranger issue, and will be harder to diagnose.

    Something that is not clear to me is if this is a ZQuest issue (tile editor), or a an issue with Zelda Classic reading combos. ZC does not 'read tiles', it reads combos which store tile data. Where you are encountering the issue, and precise details that explain what is happening (screenshots would be nice) would be quite handy to have.

    I can delve into the 1.50 tiles in ZQ, and the 1.50 combo reading in ZC, but it's hard to say how helpful that will be, which is why I asked if you can find a 2.50.x version in which this worked, so that if it broke in recent history, we can find a cause. If it broke in 2.10 or earlier--oh bio--this will be a bastard to correct.


    Featured Scripts & Headers: RPG.zh ( v. a0.97.1 ) ( RPG.zh Thread ) | Zelda 3 Thief's Town Treasure Chest Minigame (ffc) | Bobomb (enemy)
    ZScript & ZC-Related Pastebin | Quests and ZScript Repository | ZC Dev & Betas | Latest ZC 2.54 Beta | YouTube Channel
    All of the code that I create and publish here is free for use, modification and distribution under the GPL v2.0, or v3.0 where applicable..

  3. #3
    ZC Contirbutor ZoriaRPG's Avatar
    Join Date
    Oct 2006
    Location
    Prydon Academy
    Posts
    1,029
    Mentioned
    95 Post(s)
    Tagged
    1 Thread(s)
    vBActivity - Stats
    Points
    3,585
    Level
    19
    vBActivity - Bars
    Lv. Percent
    17.45%
    Daily Activity
    197.63%
    Weekly Activity
    29.38%
    Monthly Activity
    9.36%
    FWIW, the easiest thing might be to quasi-hack the entire 1.50 type loading code into ZQuest, as I had mentioned in the past. I had worked on an early version of this, which I was a bit unhappy about using, as I effectively duplicated a large number of objects that persist in memory at all times, such as maps, the combo tables, and whatnot from 1.5x.

    Now I'm not sure where I saved that blasted thing, or if it was overwritten by a git pull. It would not be hard to write again, but the sheer amount of RAM wastage concerns me with that model.

    I do not yet know if the 1.50 loading code would suffice, even if this worked, and then converting the data into usable data for 2.50.x would still be a chore. The main issue is the sizes and types of all of the structs, and data objects.

    I do have to ask: How much of a chore is it, in relation/contrast to this amount of work needed to make a 1.84 quest loader, to manually fix the combos and the tiles in the quest files after you load them?

    The culprits would be:

    1.50
    Code:
    if(!pfread(combobuf,sizeof(combo)*512,f)) {
       pack_fclose(f);
       return qe_invalid;
       }
    
    ///and
    
    
     if(header->data_flags[0])
     {
       if(!pfread(tilebuf,TILEBUF_SIZE,f))
       {
         pack_fclose(f);
         return qe_invalid;
       }
     }
     else
     {
       for(int i=0; i<TILEBUF_SIZE/4; i++)
         ((long*)tilebuf)[i]=((long*)data[TIL_NES].dat)[i];
     }
    The actual data stored in *combobuf and *tilebug have changed, so ZQuest is likely trying to read values in the wrong data locations; and iit is a miracle that it does not outright crash in the process.


    Featured Scripts & Headers: RPG.zh ( v. a0.97.1 ) ( RPG.zh Thread ) | Zelda 3 Thief's Town Treasure Chest Minigame (ffc) | Bobomb (enemy)
    ZScript & ZC-Related Pastebin | Quests and ZScript Repository | ZC Dev & Betas | Latest ZC 2.54 Beta | YouTube Channel
    All of the code that I create and publish here is free for use, modification and distribution under the GPL v2.0, or v3.0 where applicable..

  4. #4
    Wizrobe Nightmare's Avatar
    Join Date
    Mar 2000
    Age
    38
    Posts
    2,461
    Mentioned
    38 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    3,398
    Level
    18
    vBActivity - Bars
    Lv. Percent
    73.08%
    Daily Activity
    0%
    Weekly Activity
    1.13%
    Monthly Activity
    2.77%
    It didn't work in any version of 2.50. I don't know where it started honestly.

    The next step on this one is to repeat the test process creating a quest in 1.90 under the same conditions. I'll report if this build issue is limited to 1.84 or extends to all versions possibly pre 2.10.

    I think the problem is honestly the way the tiles are bound to 1.84 and earlier, though more isolation testing needs to be done to confirm.

    I posted the test files on Discord in the compatibility channel

    -James

  5. #5
    Wizrobe Nightmare's Avatar
    Join Date
    Mar 2000
    Age
    38
    Posts
    2,461
    Mentioned
    38 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    3,398
    Level
    18
    vBActivity - Bars
    Lv. Percent
    73.08%
    Daily Activity
    0%
    Weekly Activity
    1.13%
    Monthly Activity
    2.77%
    OK @ZoriaRPG , some more updates:

    2.50.x (anything) and 2.53: Basically creates a weird screen and you can't see Link or anything. Checked the file in ZQuest, and certain tiles were missing, almost as if the tiles weren't replaced. The tileset seemed to be the one that defaulted to 2.50. I had this issue running the original example_1st.qst from 1990 as well. It's almost as if the tileset doesn't carry over. Also, importing the 1.84 tileset doesn't work, it just outright fails and won't even load. I fixed the original example_1st problem by uploading the New Quest tileset (which isn't perfect old, but close enough)

    2.10.2: Outright crashes. I can't get ZC 2.10 to even work to the right directory. I personally hate 2.10 a lot, it's one of the reasons why I left years ago and didn't even develop for it outside of forum issues.

    1.92: No issues. Plays smooth, works fine. All tiles where they're supposed to be.

    Same test files as in the Discord channel.

    I am having the DOSBox team whip up a 1.90 example quest. I'll check back in a few days on that. I believe this is a 1.84- issue, but want to double-check on it before signing off on that.

    -James

    Facebook: http://www.facebook.com/nightmarejames YouTube: http://www.youtube.com/nightmarejames

    Game Projects
    Zelda Classic:
    Completed: Zelda NES Remastered, Demo 1st Quest, Demo 2nd Quest, James Quest: Remastered (V 2.1), Memorial Quest, New Quest 2 2015. New Quest: Rebuilt
    In development: Demo SP, James Quest: Remastered (V 3.0)t, 6QI

  6. #6
    Wizrobe Nightmare's Avatar
    Join Date
    Mar 2000
    Age
    38
    Posts
    2,461
    Mentioned
    38 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    3,398
    Level
    18
    vBActivity - Bars
    Lv. Percent
    73.08%
    Daily Activity
    0%
    Weekly Activity
    1.13%
    Monthly Activity
    2.77%
    The same quest layout built in 1.90 also fails built the same way in the same exact fashion as 1.84 did, and I cannot load 1.90 tile files into the 2.53 beta.

    Also fails in all versions of 2.50, plays in 1.92.

    Rebuilding test case in 1.92

    Test File available on Discord.

    -James
    Last edited by Nightmare; 10-01-2017 at 03:46 AM.

    Facebook: http://www.facebook.com/nightmarejames YouTube: http://www.youtube.com/nightmarejames

    Game Projects
    Zelda Classic:
    Completed: Zelda NES Remastered, Demo 1st Quest, Demo 2nd Quest, James Quest: Remastered (V 2.1), Memorial Quest, New Quest 2 2015. New Quest: Rebuilt
    In development: Demo SP, James Quest: Remastered (V 3.0)t, 6QI

  7. #7
    Wizrobe Nightmare's Avatar
    Join Date
    Mar 2000
    Age
    38
    Posts
    2,461
    Mentioned
    38 Post(s)
    Tagged
    3 Thread(s)
    vBActivity - Stats
    Points
    3,398
    Level
    18
    vBActivity - Bars
    Lv. Percent
    73.08%
    Daily Activity
    0%
    Weekly Activity
    1.13%
    Monthly Activity
    2.77%
    If I upload the New Quest tileset to the 184test.qst file in 2.50.2, it works perfectly.

    So essentially, this is a problem is you use the DEFAULT tileset without making a change/adding one, etc. So 1.84, 1.90, and 1.92 quests will not function properly if you didn't change a tile.

    Test quest going in Discord.

    -James

    Facebook: http://www.facebook.com/nightmarejames YouTube: http://www.youtube.com/nightmarejames

    Game Projects
    Zelda Classic:
    Completed: Zelda NES Remastered, Demo 1st Quest, Demo 2nd Quest, James Quest: Remastered (V 2.1), Memorial Quest, New Quest 2 2015. New Quest: Rebuilt
    In development: Demo SP, James Quest: Remastered (V 3.0)t, 6QI

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Armageddon Games is a game development group founded in 1997. We are extremely passionate about our work and our inspirations are mostly drawn from games of the 8-bit and 16-bit era.
Social