User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: Windows 10 Fullscreen glitches out

  1. #1
    Gel Just registered
    Join Date
    Dec 2016
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Sick Bug Windows 10 Fullscreen glitches out

    Zelda Classic on Windows 10 seems to not work in fullscreen mode unless using a program called DXGL. Is anyone else having this issue and is there a way to fix it for newer versions of Windows?

  2. #2
    Administrator War Lord's Avatar
    Join Date
    Feb 2000
    Age
    32
    Posts
    5,974
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Which version? I do believe there are issues with some of the older versions though I have not tested it myself.
    I'm running the latest stable version on Windows 10 without issue, as are others.

  3. #3
    Octorok
    Join Date
    Dec 2001
    Age
    33
    Posts
    126
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by phly95 View Post
    Zelda Classic on Windows 10 seems to not work in fullscreen mode unless using a program called DXGL. Is anyone else having this issue and is there a way to fix it for newer versions of Windows?
    Windows 10 (and also Windows 8/8.1) only support 32-bit color. The reason DXGL works is because it advertises 8, 16, and 24-bit color modes even if the version of Windows doesn't support them, and fully emulates the low-color modes.

    Without DXGL, you can attempt to make Windows emulate 8-bit color (which is what ZC uses) by right clicking on zelda-w.exe and selecting Properties. In the Compatibility tab check "Reduced color mode" and from the dropdown make sure "8-bit (256) color" is selected.

    If this works, it should also work on Windows 8 and 8.1, however there may be a severe loss of performance due to a DirectDraw bug in those versions. DXGL is not affected by this bug though because it uses OpenGL in 32-bit color mode.

  4. #4
    Is this the end?
    ZC Developer
    Saffith's Avatar
    Join Date
    Jan 2001
    Age
    34
    Posts
    3,273
    Mentioned
    139 Post(s)
    Tagged
    6 Thread(s)
    In ag.cfg, find the doublebuffer setting and be sure it's set to 1. That seems to fix a lot of these issues.
    [téknolŕiz]

    ffcscript.zh 1.1.1 - Updated 2014-08-19
    ghost.zh 2.8.1 - Updated 2016-09-16
    tango.zh 1.2.0 - Updated 2016-09-16

  5. #5
    Furry Friends Forever XMuppetSB's Avatar
    Join Date
    Dec 2005
    Location
    San Antonio, Texas
    Age
    27
    Posts
    1,915
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by Saffith View Post
    In ag.cfg, find the doublebuffer setting and be sure it's set to 1. That seems to fix a lot of these issues.
    Well, I tried changing this setting to 1 and the full screen mode still didn't work for ZC or ZQuest.

  6. #6
    Gel Just registered
    Join Date
    Dec 2016
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Actually, after using the latest beta, it seems to have resolved the problem. The stable version seems to be what is causing issues.

  7. #7
    Furry Friends Forever XMuppetSB's Avatar
    Join Date
    Dec 2005
    Location
    San Antonio, Texas
    Age
    27
    Posts
    1,915
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by phly95 View Post
    Actually, after using the latest beta, it seems to have resolved the problem. The stable version seems to be what is causing issues.
    I'm actually having these problems with the latest beta, which is 2.50.3 RC1.

  8. #8
    Developer ZC Developer
    Gleeok's Avatar
    Join Date
    Apr 2007
    Posts
    4,533
    Mentioned
    189 Post(s)
    Tagged
    8 Thread(s)
    We should probably start asking what DirectX (Direct3D)version and graphics card users have when reporting this problem.

    Would set_gfx_mode(GFX_SAFE) be any different? Also, it might be useful to print out all the fields for gfx_capabilities in allegro.log just to see if there's some correlation there. Because right now I'm out of ideas.
    This post contains the official Gleeok™ seal of approval. Look for these and other posts in an area near you.

  9. #9
    Mad, Mad, Author ZoriaRPG's Avatar
    Join Date
    Oct 2006
    Location
    Prydon Academy
    Posts
    694
    Mentioned
    61 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by Gleeok View Post
    We should probably start asking what DirectX (Direct3D)version and graphics card users have when reporting this problem.

    Would set_gfx_mode(GFX_SAFE) be any different? Also, it might be useful to print out all the fields for gfx_capabilities in allegro.log just to see if there's some correlation there. Because right now I'm out of ideas.
    The build using allegro 4.4.3 doesn't have that blue flicker, but it does have an issue where ZC outright crashes when it tries to play any non-midi music. (It also fixed at least one long-standing KB issue.) 4.4.3 uses DirectX 8, instead of DirectX 7, which is likely beneficial.

    If you, or @Saffith , or @DarkDragon want to help debug it and figure out why the audio is causing it to crash, I could port over the allegro changes easily enough.

    This crash occurs with the Windows build. The Linux build has no audio at all, at all.

    Source, if you want to examine it.


    Script Headers: RPG.zh ( v. a0.97.1 ) ( RPG.zh Thread ) | stdArguments.zh (v.6.9.9/1) | | Timers.zh (v.1.5)
    ZScript | ZC Dev | ZC 2.53 | Alucard's: stdCombos.zh (v1.1) | stdWeapons.zh | particles.z
    All of the code that I create and publish here is free for use, modification and distribution under the GPL v2.0.

  10. #10
    Administrator DarkDragon's Avatar
    Join Date
    Oct 2001
    Posts
    6,072
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Zelda Classic crashes reliably for me if I try to alt-tab out of fullscreen mode. The segfault occurs deep inside the Windows DirectDraw library (and the cause is almost certainly the (mis)use of hardware surfaces).

    I have a GeForce GTX 980 Ti and Direct3D version 12.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
Armageddon Games is a game development group founded in 1997. We are extremely passionate about our work and our inspirations are mostly drawn from games of the 8-bit and 16-bit era.
Social